formelevaluering

Brugerhjælp og support til regneark i LibreOffice Calc

Redaktør: Lodahl

Besvar
MortenNedertoft
Indlæg: 14
Tilmeldt: 25. jun 2009 13:46

formelevaluering

Indlæg af MortenNedertoft » 14. nov 2014 00:20

Jeg har en formel (taget fra række 9):

Kode: Vælg alt

=HVIS(H9="v";OG(G9>$C$3;G9<$E$3)+TYPOGRAFI(HVIS(B9=1;"Gul";"Standard"));"")
Min intention er at hvis ikke kolonne H indeholder "v", skal formlen give en tom tekststreng.
Hvis H er "v" skal formlen give SAND/FALSK, evt. markeret med gult afhængig af B=1.

Desværre giver formlen altid en tom tekststreng med gul typografi, når H ikke er "v".

Hvad foregår der?

PKO
Indlæg: 253
Tilmeldt: 17. mar 2009 14:24

Re: formelevaluering

Indlæg af PKO » 14. nov 2014 09:13

Hej,

Hvis formlen fungerer sådan:

=HVIS(udsagn; sand; falsk) hvilket leder til at din formel skal laves om til

Kode: Vælg alt

=HVIS(H9="v";"";OG(G9>$C$3;G9<$E$3)+TYPOGRAFI(HVIS(B9=1;"Gul";"Standard")))
for at lave en tom tekststreng ved H = "V".

MortenNedertoft
Indlæg: 14
Tilmeldt: 25. jun 2009 13:46

Re: formelevaluering

Indlæg af MortenNedertoft » 14. nov 2014 22:29

Hej PKO og andre
Problemet er at min formel =HVIS(kriterie; formel1; formel2)
bliver formel1 beregnet, selv når resultatet (korrekt) i cellen er formel2.
Det kan jeg se, fordi jeg bruger TYPOGRAFI funktionen i formel1.

Hvis jeg nu havde en supercomputer, kunne der være fornuft i at beregne formel1 og formel2 parallelt med kriteriet. Men vi må da stadig kræve at funktioner med bieffekter (såsom TYPOGRAFI), kun giver effekter hvis kriteriet er opfyldt.
Morten

Jens S
Indlæg: 1091
Tilmeldt: 25. mar 2007 22:42

Re: formelevaluering

Indlæg af Jens S » 15. nov 2014 19:37

Prøv med denne formel:
=HVIS(OG(H9="v";G9>$C$3;G9<$E$3;B9=1);T(TYPOGRAFI("Gul"));T(TYPOGRAFI("Standard"))

så vidt jeg kan se skal alle betingelserne være opfyldt

mvh
Jens

MortenNedertoft
Indlæg: 14
Tilmeldt: 25. jun 2009 13:46

Re: formelevaluering

Indlæg af MortenNedertoft » 16. nov 2014 00:39

Hej Jens
Hvad mener du med at alle betingelserne skal være opfyldt?
Jeg ønsker kun H="v" som betingelse.
Morten

PKO
Indlæg: 253
Tilmeldt: 17. mar 2009 14:24

Re: formelevaluering

Indlæg af PKO » 16. nov 2014 11:57

Hej Morten,

I din oprindelige formel, har du da flere kriterier(brugen af HVIS OG), der skal opfyldes. I dit seneste indlæg giver du udtryk for, at det kun er H="v".

Måske skulle du prøve at forklare lidt bedre med ord, hvad det er du vil opnå.

MortenNedertoft
Indlæg: 14
Tilmeldt: 25. jun 2009 13:46

Re: formelevaluering

Indlæg af MortenNedertoft » 20. nov 2014 22:26

Det der står efter semikolonnet er ikke et kriterie.

Kode: Vælg alt

OG(G9>$C$3;G9<$E$3)+TYPOGRAFI(HVIS(B9=1;"Gul";"Standard"));""
er formelresultatet afhængig af kriteriet H="v".
Og ja, output skal være "SAND" eller "FALSK", hvis H="v". Derudover skal typografien være "Gul", hvis B er 1.

Mit problem er at typografien ændres til "Gul", når H!="v"

Jens S
Indlæg: 1091
Tilmeldt: 25. mar 2007 22:42

Re: formelevaluering

Indlæg af Jens S » 30. nov 2014 12:59

Kunne du ikke prøve med egne ord beskrive betingelserne og hvad du vil opnå med det. Hvis du absolut selv vil opstille en formel så begynd med en enkelt udgave og byg så på den efterhånden som den virker.

mvh
Jens

Besvar

Hvem er online

Brugere der viser dette forum: Ingen og 3 gæster