Object variable not set

Brugerhjælp og support til makroer i LibreOffice Basic

Redaktører: Lodahl, LarsBrandi

Besvar
jmadsen

Object variable not set

Indlæg af jmadsen » 12. okt 2004 13:14

Hej

Jeg er ved at forsøge mig med lidt makroprogrammering i StarBasic - mit problem er, at hver eneste gang, jeg forsøger at arbejde med objekter, så får jeg fejlmeddelelsen:

Basic runtime error.
Object variable not set

Og det er uanset, om det er noget kod,e jeg snupper fra sun for at teste det af - INTET af det virker!

Hvad gør jeg forkert?

Mvh
Jane

PS. Det er StarOffice7

LarsBrandi
Indlæg: 95
Tilmeldt: 22. okt 2003 12:44
Geografisk sted: Vojens
Kontakt:

Re:Object variable not set

Indlæg af LarsBrandi » 12. okt 2004 14:33

Jeg ved ikke om dette vil hjælpe dig lidt på vej :

http://www.oooforum.org/forum/viewtopic.php?t=12255
mvh

Lars Brandi Jensen

Jmadsen

Re:Object variable not set

Indlæg af Jmadsen » 12. okt 2004 15:41

LarsBrandi skrev:Jeg ved ikke om dette vil hjælpe dig lidt på vej :

http://www.oooforum.org/forum/viewtopic.php?t=12255
Den havde jeg set uden at blive specielt meget klogere.... Men tak for svaret alligevel!

Mvh
Jane - som jo også er total nybegynder på dette punkt, så hvis nogen kan anbefale noget, så sig endelig til!

Jmadsen

Re:Object variable not set

Indlæg af Jmadsen » 12. okt 2004 16:13

Eksempelvis går denne her kopieret fra Basic Programmer's Guide på OpenOffice.org ikke:

sub main
Dim Doc As Object
Dim Enum As Object
Dim TextElement As Object
Doc = StarDesktop.CurrentComponent
Enum = Doc.Text.createEnumeration <---- Her giver den fejl!
While Enum.hasMoreElements
TextElement = Enum.nextElement
If TextElement.supportsService("com.sun.star.text.Paragraph") Then
TextElement.String = Replace(TextElement.String, "you", "U")
TextElement.String = Replace(TextElement.String, "too", "2")
TextElement.String = Replace(TextElement.String, "for", "4")
End If
Wend
end sub

Fejlen den kommer med er "Propert or method not found" - og den får jeg rimelig tit også :?: Får mig til at tænke på om jeg evt. mangler et eller andet standard library eller wtf?

Mvh
Jane

LarsBrandi
Indlæg: 95
Tilmeldt: 22. okt 2003 12:44
Geografisk sted: Vojens
Kontakt:

Lidt mere info !

Indlæg af LarsBrandi » 12. okt 2004 23:16

Hvilket styresystem bruger du ? Har du java installeret ?
mvh

Lars Brandi Jensen

Jmadsen

Re: Lidt mere info !

Indlæg af Jmadsen » 15. okt 2004 10:35

LarsBrandi skrev:Hvilket styresystem bruger du ? Har du java installeret ?
Jeg prøver både under winXP og linux og ja, jeg har java installeret...

Mvh
Jane

Besvar

Hvem er online

Brugere der viser dette forum: Ingen og 1 gæst