inline dataområde/søgekriterie

Brugerhjælp og support til regneark i LibreOffice Calc

Redaktør: Lodahl

Besvar
MortenNedertoft
Indlæg: 14
Tilmeldt: 25. jun 2009 13:46

inline dataområde/søgekriterie

Indlæg af MortenNedertoft » 13. nov 2014 22:17

Jeg vil gerne bruge DTÆLV i en kolonne med søgekriterier defineret af data fra primært samme række.
Eksemplet på siden
https://help.libreoffice.org/Calc/Datab ... mple_Data:
(Den danske tilsvarende side indeholder besynderlig forkert - og forvirrende - tekst.)
På siden er søgekriteriet ikke dynamisk, og dtæl bruges ikke integreret i dataområdet.

Jeg vil have søgekriterierne pakket som parametre til funktionen - noget i stil med:

Kode: Vælg alt

=DTÆLV(A1:E10;0;["Age";11])
hvis jeg vil vide hvor mange af børnene, der er 11 år gamle.
Alderen vil jeg så kunne angive med en cellereference, så jeg får det ønskede dynamiske søgekriterie.

Nogen bud på hvordan dette skal formuleres i LibreOffice Calc?

På forhånd tak.

Jens S
Indlæg: 1091
Tilmeldt: 25. mar 2007 22:42

Re: inline dataområde/søgekriterie

Indlæg af Jens S » 14. nov 2014 18:51

Placer kriterier i f.eks. G1=Age og G2=11
Så skal formlen se sådan ud: =DTÆL(A1:E10;3;G1:G2)
Databaseområde: A1:E10
Søgekolonne: 3 eller "Age"
Søgekriterier: G1:G2

Normalt vil jeg bruge filtrering eller en formel som
=SUMPRODUKT(C2:C10=11)
for at finde antal 11-årige.

mvh
Jens

MortenNedertoft
Indlæg: 14
Tilmeldt: 25. jun 2009 13:46

Re: inline dataområde/søgekriterie

Indlæg af MortenNedertoft » 14. nov 2014 22:32

Hej Jens
Mine dataposter ligger i rækker, så kriterierne skal derfor også helst i en række. Virker det også horisontalt?
Morten

Jens S
Indlæg: 1091
Tilmeldt: 25. mar 2007 22:42

Re: inline dataområde/søgekriterie

Indlæg af Jens S » 15. nov 2014 19:47

Nej - du skal have data i kolonner.
Men du kan da vende din tabel ved at markere den, ctrl+x (klip)
sæt markøren i A1 og brug så ctrl+shift+v (indsæt speciel)
Markering:
x Indsæt alt
Indstillinger:
x Transponer

mvh
Jens

MortenNedertoft
Indlæg: 14
Tilmeldt: 25. jun 2009 13:46

Re: inline dataområde/søgekriterie

Indlæg af MortenNedertoft » 16. nov 2014 00:57

Hej Jens.
Nej det tror jeg ikke dur.
DTÆLV kræver -svjv- poster i rækker og felter i kolonner.

Besvar

Hvem er online

Brugere der viser dette forum: Ingen og 2 gæster