hjælp til en formel til min kørselsbog

Brugerhjælp og support til regneark i LibreOffice Calc

Redaktør: Lodahl

Besvar
klf
Indlæg: 5
Tilmeldt: 1. dec 2011 16:40

hjælp til en formel til min kørselsbog

Indlæg af klf » 1. dec 2011 17:05

jeg mangler en formel så jeg kan regne ud hvor meget at jeg køre per litter.

Billede

man kan kun regne det ud fra fuld tank til næste gang at jeg har fuld tank.
så jeg har lavet en kolonne med F for hver gang at tanken har været fuld.
men kan jeg lave en formel så den regner automatisk ud hvormange kilometer jeg har kørt fra sedste F og dividere det med alle de litter at jeg har brugt fra sidste F og sette det ind i kolonde I og når jeg så forsætter med at skrive ind i regnearket at den så forsætter med det ?



jeg fik dette svar fra et andet forum, men det er til excel ov virker ikke for mig i OO.

Hej klf,

Sæt nedenstående formel i cellen I12 i dit ark, efterfølgende kan du tække den nedad til de andre celler.
Husk ikke at sætte formlen ind i I11, da den ikke kan beregne når der ikke findes tidligere værdier.

Fomlen er måske en smule lang, men det er altså også en rimelig kompliceret en af slagsen
=HVIS(E16<>"f";"";(MAKS($B$11:B16)-FORSKYDNING($A$1;SAMMENLIGN(GENTAG("f";255);$E$1:E15)-1;1))/SUMPRODUKT(($B$11:B16>B16-(MAKS($B$11:B16)-FORSKYDNING($A$1;SAMMENLIGN(GENTAG("f";255);$E$1:E15)-1;1)))*($B$11:B16<=B16);$D$11:D16))

//Allan

Jens S
Indlæg: 1091
Tilmeldt: 25. mar 2007 22:42

Indlæg af Jens S » 1. dec 2011 19:45

Der er normal ikke forskel på formler i excel og calc, men der har sneget sig fejl ind i Allan's formel, så prøv med dette:
HVIS(E16<>"f";"";(MAKS($B$11:B16)-FORSKYDNING($A$11;SAMMENLIGN(GENTAG("f";255);$E$11:E15)-1;1))/SUMPRODUKT(($B$11:B16>B16-(MAKS($B$11:B16)-FORSKYDNING($A$11;SAMMENLIGN(GENTAG("f";255);$E$11:E15)-1;1)))*($B$11:B16<=B16);$D$11:D16))
og denne formel skal placeres i I16 (og ikke I12 som Allan skriver).
Du kopierer formlen op- og nedad ved at trække i celle-håndtaget, så skulle der hver gang du har tanket fuld op komme en værdi i tilsvarende række i kolonne I.


mvh
Jens

klf
Indlæg: 5
Tilmeldt: 1. dec 2011 16:40

Indlæg af klf » 1. dec 2011 21:31

mange tak nu virker det :)

Besvar

Hvem er online

Brugere der viser dette forum: Ingen og 1 gæst