Side 1 af 1

Dato-check i sum.hvis

: 19. jan 2011 16:29
af PeterSvendsen
Hej, jeg sidder med et problem jeg ikke lige kan gennemskue hvordan omgåes.
Til et budgetark skal jeg summe nogen værdier der hører til specifikke måneder.
Simpelt set står tal/dato således:
_____A_______<u>B</u>_____
1 kr. -48,00 12-01-2011
2 kr. -64,00 17-01-2011
3 kr. -25,00 14-02-2011
Så hvordan konstruerer jeg en sum.hvis på det samlede område, men så jeg kan udtrække summen pr. måned, f.eks. -112 for januar, -25 for februar
et.c.
sum.hvis(B1:B3; måned(aktuel())=1; A1:A3) var min første indskydelse til at sammenlægge januars posteringer, men det virker niks ... så hvordan heulen kan det gøres?
hilfe!

: 19. jan 2011 16:48
af Jens S
Hej

Kunne du ikke bruge
=SUMPRODUKT(MÅNED(B1:B3)=1;A1:A3)
for januar måned

mvh
Jens

: 19. jan 2011 20:34
af PeterSvendsen
Nope, virker ikke.

: 19. jan 2011 20:42
af PeterSvendsen
Og jeg kan tilsyneladende heller ikke lave en
"dato(2011;1;1)<>dato(2011;2;1)" som HVIS kriterium for januar.
Men det må da for hede .. være muligt at gennemsøge en kolonne for datoværdier (måned) mellem dato x og y, og så benytte beløb koblet til datoværdien til en samlet sum.
Håber forklaringen er så den viser hvad problemet (tilsyneladende) er.

: 19. jan 2011 21:03
af Jens S
Jeg går ud fra at dine data er som dit eksempel, og så virker min formel. Du kan også bruge følgende:
=SUM.HVIS(MÅNED(B1:B3);1;A1:A3)
men så skal formlen indtastes som matrix-formel, afslut med ctrl+shift+enter i stedet for enter
Du har datoerne i kolonne B og beløb i kolonne A, og datoer er værdier og ikke tekst (se med ctrl+F8)

mvh
Jens

: 19. jan 2011 21:08
af PeterSvendsen
Jeg kom lige på et workaround der godt nok er temmelig quick'n'dirty.
for f.eks. februar; en sum hvis på alt >= 1. feb., fratrukket en sum af alt ældre >= 1. mar., for hvad der så er tilbage er februar måned.
Det bliver bare en forholdsvist lang kode for noget der burde eksistere som selvstændig funktion ... hvis ikke det allerede gør det, og bare ikke er mig bekendt.

: 21. feb 2011 23:27
af Jesaca
Hvis du i kolonne C laver følgende følgende formel =måned(B1), og kopier denne ned over de efterfølgende rækker, så vil du have et udtræk af hvilken måned hver post repræsenterer,

Herefter er det at lave en Sum.hvis, som det fremgår herunder:
=SUM.HVIS(C1:C3;1;A1:A2)

Herefter kan kolonne C skjules, det er blot en hjælpe kolonne.

Jeg håber det kan hjælpe dig