Tælle farvede celler

Brugerhjælp og support til regneark i LibreOffice Calc

Redaktør: Lodahl

Besvar
snyborg
Indlæg: 3
Tilmeldt: 17. dec 2009 18:49

Tælle farvede celler

Indlæg af snyborg » 17. dec 2009 18:56

Hej.

Hvordan tæller jeg antallet af farvede celler?

F.eks med udgangspunkt i denne formel =TÆL.HVIS(AL6:BY6;???)

Søren

SME
Indlæg: 163
Tilmeldt: 29. sep 2008 11:05
Geografisk sted: Silkeborg, Danmark
Kontakt:

Indlæg af SME » 18. dec 2009 09:22

Hej

Hvem har farvede cellerne?
Hvis det er brugeren, må vi desværre en tur forbi noget makro-værk. Hvis cellerne er farvede vha. betinget formateringer, kan du sammenligne på de samme værdier, som den betinget formatering.

/SME
OOo 3.1 kører fint på Vista Home Premium.

Jens S
Indlæg: 1091
Tilmeldt: 25. mar 2007 22:42

Indlæg af Jens S » 18. dec 2009 10:45

Jeg har lavet en prøve på at tælle farver med betinget formatering. se her http://dl.dropbox.com/u/2601866/T%C3%A6l%20farver.ods , men det er jo kun en mere kompliceret måde at tælle værdier på

mvh
Jens

snyborg
Indlæg: 3
Tilmeldt: 17. dec 2009 18:49

Indlæg af snyborg » 18. dec 2009 16:55

Det er brugeren der har farvet celler, der er ikke værdier i cellerne.

Det er måske ikke lige den bedste måde at bruge et regneark på, men det bruges kan man vel sige som en grafisk måde at sammentælle de timer der ikke er besat i en arbejdsplan. Så håbede jeg at man måska kunne tælle det antal røde celler der indikerer at her mangler der altså bemanding.

Håber det på en eller anden vis kan lade sig gøre, uden at sætte en værdi i cellen.

Søren

Jens S
Indlæg: 1091
Tilmeldt: 25. mar 2007 22:42

Indlæg af Jens S » 18. dec 2009 19:17

Indsæt en smal kolonne foran din tidskolonne, og fyld den ud med 0 og 1, alt efter om tiden er fri eller besat.
Sæt et betinget formatering i hjælpekolonnen(B): Celleværdi lig med 0
Typografi: Rød (som skal defineres forud)
Brug Formatpensel til at kopiere nedad

Sæt betinget formatering i tidskolonnen(C): Formlen er: $B2=0 (øverst i kolonnen)
Typografi: Rød
Brug Formatpensel til at kopiere nedad

Summere ikke besatte timer:
=SUM.HVIS(B2:B10;0;C2:C10) formateret som timer

Når du nu ændrer 0 til 1 i hjælpekolonnen, forsvinder den røde farve, og du har det overblik du ønsker.

mvh
Jens

snyborg
Indlæg: 3
Tilmeldt: 17. dec 2009 18:49

Indlæg af snyborg » 18. dec 2009 20:23

Hej Jens

Takker for din hurtige hjælp, vil straks gå i krig.

Benytter da lige muligheden og ønsker alle en glædelig jul.

Søren

Besvar

Hvem er online

Brugere der viser dette forum: Exabot [Bot] og 9 gæster