Ændring af Feltnavne i FletteMaster, når DB skifter navn

Brugerhjælp og support til tekstbehandling i LibreOffice Writer

Redaktører: Lodahl, Ejnar

Besvar
Jesper66
Indlæg: 3
Tilmeldt: 10. mar 2014 12:34

Ændring af Feltnavne i FletteMaster, når DB skifter navn

Indlæg af Jesper66 » 12. mar 2014 07:58

Hello.
Jeg er ret ny inden for LO.
Det er dog lykkedes at mig at lave et flette-doc., som baserer sig på felter, som helt enkelt henter database-data fra et regneark (ODS).
Jeg har brug for at ændre på regnearkets filnavn etc., men feltnavne er bevaret fuldstændigt.
Hvordan får jeg flette-doc'et til at erkende det nye filnavn på databasen?
Det kan vel ikke passe at jeg skal sidde og vælge det hele ud igen, når jeg i Vis=>Feltnavne dybest set bare kunne lave en Søg&Erstat?
På forhånd tak for hjælpen.

Jens S
Indlæg: 1091
Tilmeldt: 25. mar 2007 22:42

Indlæg af Jens S » 12. mar 2014 08:43

Dette er nu ikke mit speciale, men jeg kiggede på det og fandt i Menu:Rediger - Udskift database. Prøv at se om det er noget du kan bruge.

Mvh
Jens

Jesper66
Indlæg: 3
Tilmeldt: 10. mar 2014 12:34

Indlæg af Jesper66 » 12. mar 2014 09:39

Tak for svar.

Sorry - var nok ikke klar nok i spyttet første gang... ;-)

"Udskift database" er første step - dét har jeg gjort.
Men mit master flette-doc. er fyldt med feltnavne á la

OldFilename.Ark1.Felt1

Så spørgsmålet er - mere præcist:
Hvordan erstatter jeg globalt OldFilename med DB's nye NewFilename...?
Jeg mener at kunne huske at MS Word kan gøre dette med en simpel Søg&Erstat, hvis man tillader at feltnavne må medtages...

/Jesper66

NB: AltSearch finder pudsigt nok IKKE de pågældende feltnavne.....

Jens S
Indlæg: 1091
Tilmeldt: 25. mar 2007 22:42

Indlæg af Jens S » 12. mar 2014 11:33

Det lyder lidt ulogisk for mig - hvis Udskift Database ikke udskifter databasen, hvad gør den så?
En test med LO 4.2.1.1 udskiftede kun første feltnavn, men noterede kun én database tilknyttet dokumentet (den nye)??
Så prøvede jeg Apache OpenOffice 4.1.0 - og den udskiftede fint alle felter til ny database, så det er nok en fejl i LO.
Du kan godt have begge office-pakker installeret på samme pc, men LO skal installeres først.

mvh
Jens

Jesper66
Indlæg: 3
Tilmeldt: 10. mar 2014 12:34

Indlæg af Jesper66 » 13. mar 2014 07:32

Hello.

Tak for input - og tests. ;-)
Jeg kører i øvrigt på LibreOffice 3.6.

Det viser sig at der desværre er tale om en delvis "Fejl 40"...
Det er ved flere lejligheder ikke lykkedes for mig at gennemskue, hvornår og hvor "foretagne ændringer" træder i kraft / opdateres.
Dette var også tilfældet denne gang...
Jeg synes ikke at dialogen omkring udskiftningen af DB'en er specielt intuitivt indrettet....
Men - når man har luret den, synes det at virke som det skal. ;-)

Tak for hjælpen - mvh. Jesper.

Jens S
Indlæg: 1091
Tilmeldt: 25. mar 2007 22:42

Indlæg af Jens S » 18. mar 2014 11:51

Jeg lavede en nye test på udskift af database og denne gang virkede det som forventet. Prøvede også at udskifte tabellen med en forespørgsel fra samme database og det virkede også Ok. Så jeg kan kun konkludere at funktionen lejlighedsvis kan volde problemer, men ikke nok til at rapportere en fejl.

Jens

Besvar

Hvem er online

Brugere der viser dette forum: Ingen og 4 gæster