SMTP porten

Brugerhjælp og support til tekstbehandling i LibreOffice Writer

Redaktører: Lodahl, Ejnar

KnudBE
Indlæg: 21
Tilmeldt: 1. jul 2005 16:39
Geografisk sted: Dragør
Kontakt:

SMTP porten

Indlæg af KnudBE » 29. apr 2009 23:49

Jeg har et problem med porten til udgående post, som man sætter op i "Brevfletning e-mail"...

Jeg bruger min egen SMTP-server, men har Stofa som udbyder, og Stofa tillader ikke at man bruger port 25 til ekstern mailserver. Jeg skal derfor benytte port 2525.
Mit problem er, at OpenOffice absolut vil indsætte et tusindtalspunktum, så den retter min 2525 til 2.525 og det er der jo ikke nogen port der hedder...

Nu kan jeg så vente til 3.1 kommer, men det er nok ikke lige sådan et sted at der er rettet noget...
Knud Berggreen

esbe0184
Site Admin
Indlæg: 159
Tilmeldt: 27. mar 2005 19:17
Geografisk sted: 6950 Ringkøbing
Kontakt:

Re: SMTP porten

Indlæg af esbe0184 » 30. apr 2009 22:35

KnudBE skrev:Mit problem er, at OpenOffice absolut vil indsætte et tusindtalspunktum, så den retter min 2525 til 2.525 og det er der jo ikke nogen port der hedder...

Nu kan jeg så vente til 3.1 kommer, men det er nok ikke lige sådan et sted at der er rettet noget...
Jeg har kigget lidt på det, og det liner mistænkelig en fejl!

For at klargøre hvor vi er henne, så er det port under:
Funktioner -> Indstillinger -> OpenOffice.org Writer -> Brevfletning e-mail
Tools -> Options -> OpenOffice.org Writer -> Mail Merge E-mail

Under Servergodkendelse optræder den samme fejl med tusindedelsseparatoren på port. I dansksproget brugergrænseflade er det "." og i engelsksproget er det ",".

Har søgt i Issue databasen, dog uden at finde fejlen rapporteret.

Jeg vil gå i tænke boks, for at se om jeg kan opsætte et test miljø, hvor det kan afprøves om det kun er en kosmetisk fejl eller om det er en funktionel fejl.
Med venlig hilsen

Esben Aaberg

KnudBE
Indlæg: 21
Tilmeldt: 1. jul 2005 16:39
Geografisk sted: Dragør
Kontakt:

Re: SMTP porten

Indlæg af KnudBE » 30. apr 2009 23:16

esbe0184 skrev:For at klargøre hvor vi er henne, så er det port under:
Funktioner -> Indstillinger -> OpenOffice.org Writer -> Brevfletning e-mail
Tools -> Options -> OpenOffice.org Writer -> Mail Merge E-mail
Jep, det er lige præcis det sted :-)

Jeg vil sige at det er en kosmetisk fejl som har en funktionel effekt :-)

Kosmetisk, fordi man sætter et format med tusindtalsseperator hvor der ikke skal være det.
Funktionel effekt, fordi formatet ikke kan bruges i funktionen.
Knud Berggreen

esbe0184
Site Admin
Indlæg: 159
Tilmeldt: 27. mar 2005 19:17
Geografisk sted: 6950 Ringkøbing
Kontakt:

Re: SMTP porten

Indlæg af esbe0184 » 24. maj 2009 10:38

esbe0184 skrev:Jeg vil gå i tænke boks, for at se om jeg kan opsætte et test miljø, hvor det kan afprøves om det kun er en kosmetisk fejl eller om det er en funktionel fejl.
Jeg har nu teste på port 9.999 og det virker fint for mig, både med "Test indstillinger..." og afsendelse af e-mail!

Hvad er dit resultat når du trykker på Test indstillinger... under Funktioner -> Indstillinger -> OpenOffice.org Writer -> Brevfletning e-mail?
Med venlig hilsen

Esben Aaberg

KnudBE
Indlæg: 21
Tilmeldt: 1. jul 2005 16:39
Geografisk sted: Dragør
Kontakt:

Re: SMTP porten

Indlæg af KnudBE » 24. maj 2009 17:21

esbe0184 skrev:
esbe0184 skrev:Jeg vil gå i tænke boks, for at se om jeg kan opsætte et test miljø, hvor det kan afprøves om det kun er en kosmetisk fejl eller om det er en funktionel fejl.
Jeg har nu teste på port 9.999 og det virker fint for mig, både med "Test indstillinger..." og afsendelse af e-mail!

Hvad er dit resultat når du trykker på Test indstillinger... under Funktioner -> Indstillinger -> OpenOffice.org Writer -> Brevfletning e-mail?
Jeg tvivler på at det virker. Jeg har aldrig hørt om at man kan sende mails på andet end porte som specifikt er sat op til det formål, og der er det normalt kun port 25. I visse tilfælde tillades også en anden port, hvilket typisk er 2525.
Jeg tvivler på at nogen har sat port 9.999 op som mailgateway. Og hvis det endelig skulle være, så tror jeg faktisk at der er forskel på 9.999 og 9999.
Jeg kan forestille mig at du har brugt din internetudbyders smpt-server, og at denne ikke tjekker på porten når det er indenfor eget netværk.

Hos min mailudbyder kan kun anvendes port 25 og port 2525. Ikke port 2.525. I øvrigt så skriver jeg ikke 2.525 men 2525 og så skal det så sandelig ikke ændres.
Knud Berggreen

esbe0184
Site Admin
Indlæg: 159
Tilmeldt: 27. mar 2005 19:17
Geografisk sted: 6950 Ringkøbing
Kontakt:

Re: SMTP porten

Indlæg af esbe0184 » 24. maj 2009 17:56

KnudBE skrev:Jeg tvivler på at det virker. Jeg har aldrig hørt om at man kan sende mails på andet end porte som specifikt er sat op til det formål, og der er det normalt kun port 25. I visse tilfælde tillades også en anden port, hvilket typisk er 2525.
Jeg tvivler på at nogen har sat port 9.999 op som mailgateway. Og hvis det endelig skulle være, så tror jeg faktisk at der er forskel på 9.999 og 9999.
Jeg kan forestille mig at du har brugt din internetudbyders smpt-server, og at denne ikke tjekker på porten når det er indenfor eget netværk..
Jeg ændret Exchangeserveren til at modtage smtp på port 9999, og prøvede så med port 9999 (9.999) i OpenOffice.org, hvilket virkede.
Efterfølgende prøvede jeg med 9998 i OpenOffice.org hvilket ikke virkede, for at sikre at det ikke var en afhængighed af port 25.
Så hvilket porte der normal bruge som alternativ port er mindre interessant.

Når jeg brugte port 9998 kom testen ud med at jeg godt kunne se serveren men ikke porten.

Du kan også prøve at lave en telnet til serveren:

telnet 80.x.x.x 2525

så kan du see om der er en smtp-server der svare.

for at komme ud af smtp-serveren skriv:

quit
Med venlig hilsen

Esben Aaberg

KnudBE
Indlæg: 21
Tilmeldt: 1. jul 2005 16:39
Geografisk sted: Dragør
Kontakt:

Indlæg af KnudBE » 24. maj 2009 18:31

Hmmm...
Jeg ved ikke om der er sket en opdatering, men nu er der ingen af de 4 e-mail-muligheder som benytter OO som mailklient. Alle bliver blot til vedhæftede filer i mit mailprogram.

Så den benytter slet ikke e-mail-indstillingerne længere...?
Knud Berggreen

cykelsmeden
Indlæg: 18
Tilmeldt: 1. jul 2008 11:20

Re: SMTP porten

Indlæg af cykelsmeden » 1. jun 2009 21:26

KnudBE skrev:
esbe0184 skrev:
esbe0184 skrev:Jeg vil gå i tænke boks, for at se om jeg kan opsætte et test miljø, hvor det kan afprøves om det kun er en kosmetisk fejl eller om det er en funktionel fejl.
Jeg har nu teste på port 9.999 og det virker fint for mig, både med "Test indstillinger..." og afsendelse af e-mail!

Hvad er dit resultat når du trykker på Test indstillinger... under Funktioner -> Indstillinger -> OpenOffice.org Writer -> Brevfletning e-mail?
Jeg tvivler på at det virker. Jeg har aldrig hørt om at man kan sende mails på andet end porte som specifikt er sat op til det formål, og der er det normalt kun port 25. I visse tilfælde tillades også en anden port, hvilket typisk er 2525.
Jeg tvivler på at nogen har sat port 9.999 op som mailgateway. Og hvis det endelig skulle være, så tror jeg faktisk at der er forskel på 9.999 og 9999.
Jeg kan forestille mig at du har brugt din internetudbyders smpt-server, og at denne ikke tjekker på porten når det er indenfor eget netværk.

Hos min mailudbyder kan kun anvendes port 25 og port 2525. Ikke port 2.525. I øvrigt så skriver jeg ikke 2.525 men 2525 og så skal det så sandelig ikke ændres.
Det må være attributterne for tekstfeltet der er galt - simpel integer?
iøvrigt er der ikke nogen begrænsning på hvilken port man kan bruge til smtp. Jeg har gennem tiden stort set brugt hvadsomhelst, men plejer at holde mig til 3 cifre, typisk 125, 225, 325 osv. Meget praktisk til smtpproxy som assp ol. hvor første ciffer så angiver nummeret i et flow :-)
selvfølgeligt skal det aftales med modtagende smtpserver, her udbyder.
--
Linux er som en TeePee:
no Gates, no Windows and a working Apache inside

KnudBE
Indlæg: 21
Tilmeldt: 1. jul 2005 16:39
Geografisk sted: Dragør
Kontakt:

Re: SMTP porten

Indlæg af KnudBE » 1. jun 2009 22:54

cykelsmeden skrev: Det må være attributterne for tekstfeltet der er galt - simpel integer?
Ja, formodentlig.
cykelsmeden skrev:iøvrigt er der ikke nogen begrænsning på hvilken port man kan bruge til smtp. Jeg har gennem tiden stort set brugt hvadsomhelst, men plejer at holde mig til 3 cifre, typisk 125, 225, 325 osv. Meget praktisk til smtpproxy som assp ol. hvor første ciffer så angiver nummeret i et flow :-)
Det har du sandsynligvis ret i...
cykelsmeden skrev:selvfølgeligt skal det aftales med modtagende smtpserver, her udbyder.
Og det har du helt ret i. Det er dog min erfaring, at man ikke bare kan få udbyderen til at sætte hvilken som helst port.

Jeg bruger Stofa som udbyder men ikke deres smpt-server. Stofa tillader ikke port 25-trafik til andet end deres egen smpt-server, men da min mail/webhoteludbyder tillader både port 25 og 2525 så kan jeg bruge 2525 (men ikke 2.525) når jeg skal sende mails.
Knud Berggreen

cykelsmeden
Indlæg: 18
Tilmeldt: 1. jul 2008 11:20

Re: SMTP porten

Indlæg af cykelsmeden » 2. jun 2009 05:27

KnudBE skrev:
cykelsmeden skrev:
cykelsmeden skrev:selvfølgeligt skal det aftales med modtagende smtpserver, her udbyder.
Og det har du helt ret i. Det er dog min erfaring, at man ikke bare kan få udbyderen til at sætte hvilken som helst port.

Jeg bruger Stofa som udbyder men ikke deres smpt-server. Stofa tillader ikke port 25-trafik til andet end deres egen smpt-server, men da min mail/webhoteludbyder tillader både port 25 og 2525 så kan jeg bruge 2525 (men ikke 2.525) når jeg skal sende mails.
Jeg bruger hjemme dk-tv, som har det overordnede princip, at kunder med fast IP default har åbent for alt, mens dem med dyn.IP har lukket for nærmere bestemte porte, bl a smtp. Men de hjælper gerne i bestemte situationer, hvis man har en fornuftig begrundelse. Om en fejl i ens tekstbehandler så er fornuftig nok til at fravige deres standard er en anden sag. Men i et lokalt -stort eller lille, system kan der være mange fornuftige årsager til at flytte rundt på smtp-porte.
--
Linux er som en TeePee:
no Gates, no Windows and a working Apache inside

KnudBE
Indlæg: 21
Tilmeldt: 1. jul 2005 16:39
Geografisk sted: Dragør
Kontakt:

Indlæg af KnudBE » 3. jun 2009 19:32

Jeg synes faktisk at problemet flyttes et forkert sted hen her...

Vi kan vel være enige om, at når programmet ændrer væsentlige ting, så som portnumre, 4-cifrede passwords m.m. til at være 5-cifrede indeholdende et punktum, som jeg ikke har sat, så er det en fejl i programmet og har intet med min udbyder at gøre???
Knud Berggreen

esbe0184
Site Admin
Indlæg: 159
Tilmeldt: 27. mar 2005 19:17
Geografisk sted: 6950 Ringkøbing
Kontakt:

Indlæg af esbe0184 » 3. jun 2009 20:02

KnudBE skrev:Jeg synes faktisk at problemet flyttes et forkert sted hen her...

Vi kan vel være enige om, at når programmet ændrer væsentlige ting, så som portnumre, 4-cifrede passwords m.m. til at være 5-cifrede indeholdende et punktum, som jeg ikke har sat, så er det en fejl i programmet og har intet med min udbyder at gøre???
Nej, vi er ikke enige! Programmet vælger at vises port med tusindtals separationstegn, hvilket gør det letter at læse! Dog vil jeg give dig ret i at jeg også ville fortrække at den ikke gjorde det.

Når programmet kontakter SMTP-serveren bruger den ikke tusindtals separationstegnene.

Jeg har ikke mulighed for at teste med password, da det er baseret på IP-adresse om jeg må sende e-mail via SMTP eller ej.
  • :?: Hvordan gik det med de test jeg forslog dig at lave?
Med venlig hilsen

Esben Aaberg

KnudBE
Indlæg: 21
Tilmeldt: 1. jul 2005 16:39
Geografisk sted: Dragør
Kontakt:

Indlæg af KnudBE » 3. jun 2009 21:30

Jeg tror nu at den bruger 1000-talsseparatoren...

Jeg ved ikke hvordan jeg skal lave den test. Jeg har ikke kendskab til mailserverens ip-adresse.
Knud Berggreen

KnudBE
Indlæg: 21
Tilmeldt: 1. jul 2005 16:39
Geografisk sted: Dragør
Kontakt:

Indlæg af KnudBE » 3. jun 2009 21:48

Nu lavede jeg en test hvor jeg brugte servernavnet.
Jeg kan få fat gennem port 2525 men ikke port 25 så det er som forventet.

Men Oo er åbenbart blevet ændret, for den fejler ikke længere med test af forbindelsen...

Hvorfor sender den så ikke dokumentet som mail, men åbner blot en ny mail i min mailklient, hvor dokumentet er vedhæftet?
Knud Berggreen

esbe0184
Site Admin
Indlæg: 159
Tilmeldt: 27. mar 2005 19:17
Geografisk sted: 6950 Ringkøbing
Kontakt:

Indlæg af esbe0184 » 3. jun 2009 21:57

KnudBE skrev:Jeg tror nu at den bruger 1000-talsseparatoren...
Nu er det sådan at jeg har testet, og det virker for mig, så det gør den ikke... men lad os komme videre og få løst dit problem.
KnudBE skrev:Jeg ved ikke hvordan jeg skal lave den test. Jeg har ikke kendskab til mailserverens ip-adresse.
(1) Hvad er dit resultat når du i OpenOffice.org trykker på Test indstillinger... under Funktioner -> Indstillinger -> OpenOffice.org Writer -> Brevfletning e-mail?


(2) Fra en kommandoprompt, hvor smtp.dinisp.dk erstattes med den adresse du har fået oplyst!
  • telnet smtp.dinisp.dk 2525
Post evt. fejlkode og tekst.

Her et eksempel hvor det gå godt på port 25.
telnet uc-rksk.dk 25
220 post.uc-rksk.dk ESMTP (24549c27299f4112e9a4c77650509278)
quit
221 Bye
Med venlig hilsen

Esben Aaberg

Besvar

Hvem er online

Brugere der viser dette forum: Ingen og 8 gæster