formelevaluering

Brugerhjælp og support til regneark i LibreOffice Calc

Moderator: Lodahl

Post Reply
MortenNedertoft
Posts: 14
Joined: Thu Jun 25, 2009 12:46

formelevaluering

Post by MortenNedertoft » Fri Nov 14, 2014 0:20

Jeg har en formel (taget fra række 9):

Code: Select all

=HVIS(H9="v";OG(G9>$C$3;G9<$E$3)+TYPOGRAFI(HVIS(B9=1;"Gul";"Standard"));"")
Min intention er at hvis ikke kolonne H indeholder "v", skal formlen give en tom tekststreng.
Hvis H er "v" skal formlen give SAND/FALSK, evt. markeret med gult afhængig af B=1.

Desværre giver formlen altid en tom tekststreng med gul typografi, når H ikke er "v".

Hvad foregår der?

PKO
Posts: 247
Joined: Tue Mar 17, 2009 14:24

Re: formelevaluering

Post by PKO » Fri Nov 14, 2014 9:13

Hej,

Hvis formlen fungerer sådan:

=HVIS(udsagn; sand; falsk) hvilket leder til at din formel skal laves om til

Code: Select all

=HVIS(H9="v";"";OG(G9>$C$3;G9<$E$3)+TYPOGRAFI(HVIS(B9=1;"Gul";"Standard")))
for at lave en tom tekststreng ved H = "V".

MortenNedertoft
Posts: 14
Joined: Thu Jun 25, 2009 12:46

Re: formelevaluering

Post by MortenNedertoft » Fri Nov 14, 2014 22:29

Hej PKO og andre
Problemet er at min formel =HVIS(kriterie; formel1; formel2)
bliver formel1 beregnet, selv når resultatet (korrekt) i cellen er formel2.
Det kan jeg se, fordi jeg bruger TYPOGRAFI funktionen i formel1.

Hvis jeg nu havde en supercomputer, kunne der være fornuft i at beregne formel1 og formel2 parallelt med kriteriet. Men vi må da stadig kræve at funktioner med bieffekter (såsom TYPOGRAFI), kun giver effekter hvis kriteriet er opfyldt.
Morten

Jens S
Posts: 1091
Joined: Sun Mar 25, 2007 21:42

Re: formelevaluering

Post by Jens S » Sat Nov 15, 2014 19:37

Prøv med denne formel:
=HVIS(OG(H9="v";G9>$C$3;G9<$E$3;B9=1);T(TYPOGRAFI("Gul"));T(TYPOGRAFI("Standard"))

så vidt jeg kan se skal alle betingelserne være opfyldt

mvh
Jens

MortenNedertoft
Posts: 14
Joined: Thu Jun 25, 2009 12:46

Re: formelevaluering

Post by MortenNedertoft » Sun Nov 16, 2014 0:39

Hej Jens
Hvad mener du med at alle betingelserne skal være opfyldt?
Jeg ønsker kun H="v" som betingelse.
Morten

PKO
Posts: 247
Joined: Tue Mar 17, 2009 14:24

Re: formelevaluering

Post by PKO » Sun Nov 16, 2014 11:57

Hej Morten,

I din oprindelige formel, har du da flere kriterier(brugen af HVIS OG), der skal opfyldes. I dit seneste indlæg giver du udtryk for, at det kun er H="v".

Måske skulle du prøve at forklare lidt bedre med ord, hvad det er du vil opnå.

MortenNedertoft
Posts: 14
Joined: Thu Jun 25, 2009 12:46

Re: formelevaluering

Post by MortenNedertoft » Thu Nov 20, 2014 22:26

Det der står efter semikolonnet er ikke et kriterie.

Code: Select all

OG(G9>$C$3;G9<$E$3)+TYPOGRAFI(HVIS(B9=1;"Gul";"Standard"));""
er formelresultatet afhængig af kriteriet H="v".
Og ja, output skal være "SAND" eller "FALSK", hvis H="v". Derudover skal typografien være "Gul", hvis B er 1.

Mit problem er at typografien ændres til "Gul", når H!="v"

Jens S
Posts: 1091
Joined: Sun Mar 25, 2007 21:42

Re: formelevaluering

Post by Jens S » Sun Nov 30, 2014 12:59

Kunne du ikke prøve med egne ord beskrive betingelserne og hvad du vil opnå med det. Hvis du absolut selv vil opstille en formel så begynd med en enkelt udgave og byg så på den efterhånden som den virker.

mvh
Jens

Post Reply

Who is online

Users browsing this forum: No registered users and 4 guests