Felter vises fejlagtigt tomme i forespørgsler

Brugerhjælp og support til databaser i LibreOffice Base

Moderator: Lodahl

Post Reply
thvedel
Posts: 2
Joined: Sun Jun 12, 2011 13:52

Felter vises fejlagtigt tomme i forespørgsler

Post by thvedel » Wed Mar 13, 2013 8:58

Jeg oplever at resultatet af forespørgsler undertiden vises forkert, især på felter som der sættes kriterium på. Helt aktuelt bruger jeg Base som frontend imod en PostgreSQL database som indeholder dato- og klokkeslæt-felter (SQL typerne TIME og DATE).

Hvis jeg medtager disse felter i forespørgsler vises de uden problemer med mindre jeg samtidig sætter kriterier på. Hvis jeg eksempelvis afgrænser et klokkeslæt til at være lig med '08:00' vises udtrækket fint, bortset fra at dette ene felt ser ud til at være tomt (hvilket det ikke er).

Hvis jeg vælger at kopiere indholdet af forespørgslen til Calc hentes tidspunkterne fint med over, så der er alene tale om en "visnings-ting".

Er der nogen der har idé til en løsning?

Bonus-info
Ovenstående gælder i LibreOffice 4.0.1 på Windows 7 64 bit

Hvis jeg bruger LibreOffice 3.6 er felterne ikke "blanke", men til gengæld vises klokkeslæt konsekvent som "brøkdele af dagen" og datoer vises som fortløbende numre. Eksempelvis bliver kl. 06:00 angivet som 0.25.

I LibreOffice 3.6 eksporteres resultatet af forespørgslen - på samme måde som med version 4.0 - korrekt. Det er kun visningen i Base som er fejlbehæftet

Post Reply

Who is online

Users browsing this forum: No registered users and 4 guests